How to allow chromecast to work through SonicWall when Device and Chromecast are on separate Zone
03/26/2020 93 People found this article helpful 396,647 Views
Description
SonicWall does not allow chromecast to work through it by default
Cause
Chromecast require enabling multicast traffic through the SonicWall. As it is not enabled by default on SonicWall, that is why chromecast does not work through SonicWall.
Resolution
Please see the following Solution to enable multicast on SonicWall
Enabling Multicast[[|170505657227589]]
We need to enable multicast on the firewall as well as the interfaces associated with chromecast
**This solution is for the case if the client and the Chromecast are on separate Zones**
We need to be sure of the following :
- Your Client (Device trying to Connect to Chromecast) and your Chromecast are on SEPARATE zones. For example: Client is on the LAN and the Chromecast is on say, a wireless zone.
- The Wireless Access Point(s) that the Chromecast is connected to are already configured for Multicast
Now to get chromecast to work with SonicWall, Please do the following:
-Under Firewall setting> Multicast, Uncheck the box titled Require IGMP Membership reports for multicast data forwarding
-Select the radio button titled: Enable reception of all multicast addresses
-Click Accept at the top
- In the Firewall > access rules, Make sure you have allowed the traffic from the zones associated with Chromecast and the multicast zone.
E.G. LAN > MULTICAST > Allow> any> any
Note: Multicast zone is automatically created when we enable multicast on SonicWall under Firewall settings
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