Workplace切断時に「プロキシサーバは応答していません」と表示される。

Description

Workplace切断時に「プロキシサーバは応答していません」と表示される。

 

OnDemand Tunnelアクセス時において、VPN接続後、内部プロキシを経由してインターネット接続を実現している際、WorkPlaceサイトからログアウトボタンから切断しようとすると、正常に切断されずに「プロキシサーバは応答していません」と表示されます。

※Redirect Allを使用し、且つInternal Proxyを経由してインターネットに接続している場合。

 

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Cause

 内部プロキシを有効にした際に、プライベートIPアドレスのみがプロキシの除外リストとして、pacファイルが生成されます。

しかし、プライベートIPアドレスにマッピングされているworkplaceのグローバルIPアドレスに関しては除外リストに含まれていないため、本事象が発生いたします。

Resolution

解決方法として、内部プロキシサーバの除外リストにWorkplaceのIPアドレスを加えることで、内部プロキシの影響を受けることなく切断することが可能となります。

 

【設定手順】

1.  SMA管理画面より、内部プロキシ経由(Redirect All + 内部プロキシ使用)でインターネット疎通を実現しているRealmを選択します。

 User Access - Realmsから該当のAccess Methodをクリックします。

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2. Network tunnel client (OnDemand)画面より、Configureをクリックします。

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3. Proxy options - Proxy serverの箇所のExclusion list:に、ユーザが外部からWorkplaceにアクセスする際のIPアドレスを追加しOKを押します。

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4. Saveを押した後、Pending Change - Apply changeを実行します。

 

5. 再度ユーザからWorkplaceにアクセスし、切断後、エラーメッセージが表示されず問題なく切断されていることを確認します。

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