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Disable storage of last logged in username or disable Caching Username in Connect Tunnel.

03/26/2020 4 People found this article helpful 194,340 Views

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    Description

    Connect Tunnel Not to store last logged in username or not to Cache Username.

    Cause

    As per security policy for  certain organization's post logout of Users Connect Tunnel  session they would prefer not to display the username field (Last logged in Username).

    Cached Username

    Post logout Username field to be cleared or empty.

    Resolution

    Requisites:

    • SMA 1000 Series Appliance to be with 11.4.0-486 and to be applied with Pform-hotfix-686 and Clt-hotfix-686.

     

    • Connect Tunnel Client to be downloaded from specific appliance which has above hotfix. (11.4.0.421 or above). or upgrade to specific client version post applying of hotfix.
    • Select Secure Mobile Access| Management Console| User Access | Realms | Select desired Realm | Specific community| Access Methods| Tunnel (IP Protocol) | configure| User Cached credentials set to Never.

          Eg: Connect Tunnel options for desired community:

    community not to cache

    • CEM  Keyname set to  EVPN_DISABLE_USERNAME_CACHE  and Value set to 1.  (Recommended to be applied under SonicWALL Technical Support Guidance).

     cem not to cache uname

     Once the above pre-requisites and Configuration changes are made,  All  consecutive logins will have Username field empty or cleared.

     

    cleared Username

    Troubleshooting steps:

    How to verify if the CEM Value is applied correctly or not?

    SSH to the appliance and execute below script displays the CEM Value?

    ssh cat

    Post tunnel Connection on local users Machine a key value gets added to the registry:

    As Dont Cache Uname set to 1.

    RegistryUpdate

     

    This solution has been tested and verified to be functional.

    Corrupt Connect Tunnel Installers could be uninstalled or cleared with help of Clientcleanup Utility. 

    NOTE:  Info that needs to be  provided for Technical Support for Troubleshooting:

    1.  Client Operating System version and updates applied to the Operating System.
    2. Connect Tunnel Client Version.
    3. CEM Value applied Screenshot from GUI as well as SSH.
    4. This fix would work with all proper Connect Tunnel Client Laptops / Desktop installs.

    ISSUE ID:

    DTS 190273

    Related Articles

    • Printer Redirection with RDP through Secure Mobile Access
    • EPC check based on Windows version
    • SMA1000: How to manage Connect Tunnel client Auto-updates

    Categories

    • Secure Mobile Access > SMA 1000 Series > Connect Tunnel Client

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