Mobile Connect for iOS 5.0 にアップグレード後SSL-VPN接続ができなくなる

Description

以前のバージョンのMobile Connect for iOS を使用してSSL-VPN接続が正常にできていた端末でMobile Connect for iOS 5.0にアップグレードするとSSL-VPN接続に失敗する問題が発生する場合があります。

Cause

この問題は、End Point Controlで iOS Device の Device ID をチェックしている場合に発生します。

 

Appleのガイドラインでは、セキュリティ上の理由によりUDIDを取得するアプリケーションを禁止しており、それに代わりデバイス毎かつアプリケーションベンダー固有のUUIDの使用を推奨しております。

これに伴い、以前のMobile Connectバージョンでは、古いAppleのVPN APIを使用してUDIDを取得しDevice IDとしていましたが、Mobile Connect for iOS 5.0 では、Apple のガイドラインに従い Network Extension API を使用してUUIDを取得しDevice IDとするように変更になっています。

 

そのため、お客様のSSL-VPNサーバ装置上のiOS デバイスの Device ID 情報と実際のiOS デバイスのDevice IDが異なるため、EPCのチェックで接続失敗となっています。

 

Resolution

この問題に関するSonicWall 製品側の解決方法はありません。

お客様のSSL-VPNサーバ上の Device ID 情報リストの更新をお願いいたします。以下にこの方法の例を説明します。実際の方法についてはお客様環境個別にご対応をお願いいたします。

 

 SMA1000シリーズの場合:

 

1. Management Console | Logging | View Logs | Unregistered Device logs を確認し、該当ユーザのUnregistered Device Logを探します。

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2.管理者はこの情報をもとに手動でユーザプロファイルのDeviceIDを新しいDeviceIDに書き換えることが可能です。

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3. Active Directory サーバのADSI エディタを使用してユーザのプロパティを編集します(この例ではSSL-VPNユーザがadministratorなのでAdministratorのプロパティを開きます)。この例ではcommentをDeviceIDのフィールドとして使用しているとします。Image

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SMA100シリーズの場合(8.6 以上の場合。8.5以下の手順はサポートセンターにお問い合わせください):

1. SMA 100アプライアンスの場合、ログにDevice Managementのログが記録されます。以下の場合testというユーザ名で検索を行っています。

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2.デバイス管理|デバイス で該当ユーザのDevice IDを確認の上”承認”もしくは”拒否”を行います。

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