CSE Connector for Windows can't start

Description

This article explains why the CSE Connector for Windows is unable to start also on fresh server deployments.

Cause

The Installation Process runs fine, also the Connectivty Check is successful but the VPN is not UP.

Image

Service can be manually started from Windows Service Snap-In but crashes after few seconds.
Image

The Connector.log file located under "C:\Program Files\SonicWall\Connector\Logs" reports:

Image


(utils.PanicCrash:11) panic detected: Error loading wireguard.dll DLL: Unable to load library: The specified module could not be found.: stack trace: goroutine 12 [running]:
runtime/debug.Stack()

Resolution

Install the latest version of Microsoft Visual C++ Redistributable from Microsoft Website and restart the server.

Related Articles

  • Authorization Error: Unregistered user device with email
    Read More
  • CSE provisioning never completes when MySonicWall Company name does not start with a letter
    Read More
  • Routing Cloud Secure Edge (CSE) Traffic to Remote Sites via Site-to-Site VPN
    Read More
not finding your answers?