Cloud Secure Edge : Bad Request Connector ID does not match a valid Connector. Please contact your administrator for resolution on iOS and Android mobile apps

Description

Bad Request Connector ID does not match a valid Connector Please contact your administrator for resolution on iOS and Andriod as well.

The first time they connect it is fine, but any further connections show the above error.

After successfully connecting the CSE app on any Android or IOS device for the first time, the device receives the error message after the 24-hours login time has expired.

Cause

Bad Request: Connector ID does not match a valid Connector. Please contact your administrator for resolution on iOS and Android with Mobile Apps

 

Image

Resolution

The official fix will be added in upcoming patch, which is expected in the mid of October-2025.

Fix version : 2025-10-15

Issue ID

BC-17680

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