Service Unavailable Error

Description

Unable to access Hosted Websites, browsers show a ‘Service Unavailable’ error.

 

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Cause

The Service Unavailable error message occurs if the backend service is not up and running or AccessTier/Connector is unable to reach the backend service.

Resolution

1.- Run a ‘Test Connection’ from Banyan Command Center.


Private Access > Hosted Websites > Click the name of the Hosted Website > Click the button in the top right to run the test.

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Test will show if there are any issues reaching the backend service.

 

E.g.:

 

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2.- Take a capture on the Access tier (or Connector).

 

** You will need to know the real IP of the website you're trying to reach (backend service).

 

** Open a CLI to the Access Tier and get ready to start the packet capture with the command "sudo tcpdump -i any -w host ".

 

E.g:

sudo tcpdump -i any -w capturesw.pcap host 172.31.14.131

 

** Attempt to access the hosted site.

 

** Let this complete and fail.

 

** Stop the capture (Control+C).

 

** Download and analyze the capture.

 

3.- Make sure there are no security groups, firewall rules, etc blocking communication between AccessTier/Connector and backend service on desired port.

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