How to use Net API as client probing method for SSO agent when getting error as "SSO agent reported error - Error communication with OS error" ?

Description

This article provide information on how to use the NetAPI probing method when SSO user test is failed due to WMI failure or when getting error as "SSO agent reported error - Error communication with OS error".

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Cause

This error is caused by a WMI failure . When no user OS logged in, WMI gets a response as "getFields failed" which is represented by SonicOS as a negative number.

NetAPI can be used in this scenerio to avoid this error.

Resolution

  • Open SSO agent.
  • Navigate to properties.
  • In Client probing method drop down select the probing method as "Probe user using NetAPI first then WMI.
  • Click on Accept.
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  • Now login to firewall management page.
  • Navigate to Manage |Users. Click on Local users & Groups.
  • Click on Configure SSO.
  • Make sure the details of the SSO is correct.
  • Navigate to Test option.
  • Under Test select "Check User".
  • Enter the workstation IP addreess.
  • Make sure the radio button is set to "Via NetAPI/WMI".
  • Click on Test.
  • Now the User Test will success.
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  • Under Information returned from the agent, We will be able to see that the "User is identified via NetAPI".


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