Installing Connect Tunnel Client disrupts the Client Host network

Description

Uninstalling an existing Connect Tunnel Client installation while "Restrict network access to VPN only" is enabled will cause subsequent installations of Connect Tunnel Client to disrupt the network access on the client host computer.

Cause

The issue occurs when the Secure Mobile Access appliance option "Restrict network access to VPN only" is enabled
- This option restricts network access on client interfaces
- When this setting is enabled Connect Tunnel Client should not be uninstalled

Resolution

To uninstall the Connect Tunnel Client "Restrict network access to VPN only" must be disabled in the config
- User should connect to the User VPN once so the option is disabled on client
- Then we can uninstall the client successfully

When the Client Host is already in a state where internet access is blocked
- We have to do some registry cleanup to restore the network access

Restore Network Access:
- Open registry editor, and navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\BFE\Parameters\Policy\Persistent\Provider
- Delete DWORD value with GUID {9DEA27BC-1C38-4052-8265-36A49276FB82}
- Reboot the Client Host

Related Articles

  • How to Provision SMA1000 in Monthly Billing (MSSP Program)
    Read More
  • SMA 1000 Series Support Matrix
    Read More
  • How to Configure SAML 2.0 SSO with Microsoft Entra ID for SonicWall SMA 1000 Series
    Read More
not finding your answers?