How to fix the Analytics Syslog-based reports with different timestamp issues

Description

This article describes an issue related to the timestamp on Analytics Syslog-based reports. It only happens with syslogs generated by Gen7 devices when the Display UTC in logs (instead of local time) option needs to be disabled.

Cause

Syslogs generated in local time and not on UTC

Resolution

See below how to fix the issue:


1) A fix is available for this issue in the form of a HF from JIRA GEN7-31255.
NOTE: Once confirmed with tech support, apply the fix to the firewall. 

2) Apply it to the firewall, according to KB How can I upgrade SonicOS Firmware?

3) Enable Display date in International format on Device | System | Time.

Image











4)
Enable Display Syslog Timestamp in UTC on Device | Log | Syslog Settings.

Image










5) Set the proper timezone on the Analytics reports, under firewall Status.

Image

Related Articles

  • Supported SonicWall and 3rd party SFP and SFP+ modules that can be used with SonicWall TZ series
    Read More
  • How to find out the CFS rating of a website?
    Read More
  • Supported Storage Modules on SonicWall Firewalls running SonicOS/X 7 and above
    Read More
not finding your answers?