How to enable debug logs and packet capture in Mobile connect on Windows 10

Description

How to enable debug logs and packet capture in Mobile connect on Windows 10

Cause

When experiencing connectivity issues with Mobile connect on Windows 10 the packet capture as well as the debug logs need to be enabled. 

Resolution

In order to turn on these two options the following commands need to be executed in PowerShell (run as administrator):

Enable debug logging and packet capture:


$xml = "<MobileConnect><DebugLogging>true</DebugLogging><PacketCapture>true</PacketCapture></MobileConnect>"

$sourceXml=New-Object System.Xml.XmlDocument

$sourceXml.LoadXml($xml)

Add-VpnConnection -Name VPN -ServerAddress vpn.example.com -SplitTunneling $True -PluginApplicationID SonicWall.MobileConnect_e5kpm93dbe93j
-CustomConfiguration $sourceXml


Once enabled the packet capture and the debug logs can be found in the following directory:

 

C:\Users\<username>\AppData\Local\Packages\SonicWall.MobileConnect_e5kpm93dbe93j\LocalState\Logs\MobileConnect.ppp.pcap

C:\Users\<username>\AppData\Local\Packages\SonicWall.MobileConnect_e5kpm93dbe93j\LocalState\Logs\MobileConnect.log

 

After reproducing the issue please provide both files to Sonicwall Technical support for analysis

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