Mobile Connect 5.0.0 not able to connect to IPv4 server from IPv6-only network

Description

Customers who upgrade to Mobile Connect 5.0.0 may encounter a connection error when connecting from an IPv6-only network. To confirm your device is using an IPv6 address open the Mobile Connect app and navigate to Settings | Device Information.

Image

Cause

Steps to reproduce:

  1. Upgrade the IOS to 11.0.3 and MC to 5.0.0.
  2. Configure the profile in the MC.
  3. Try to connect. It stays in "connecting" status.
  4. After sometime it disconnects.

Resolution

This issue is currently scheduled to be fixed in an upcoming release of Mobile Connect; version 5.0.2.

In the mean time a workaround exists. Access the server by a hostname, rather than by raw IPv4 address. This will require one of the following.

Option 1: Set up a DNS record for the hostname. The record can be an IPv4 record (A), or an IPv6 record (AAAA) if the server also has a native IPv6 address.

Option 2: Use a hostname of "<IP address>.nip.io". Nip.io is a free service which is not operated by SonicWall; please see nip.io - Wildcard DNS for any IP for more info on that service.

Related Articles

  • SMA100 End of Support No-Charge Replacement FAQ
    Read More
  • SMA1000: Post upgrade to 12.5.0 on AWS and Azure, we show the error Could not retrieve the DNS settings once we log in to AMC/CMS console
    Read More
  • Firmware version required to upgrade to version 12.5.0.
    Read More
not finding your answers?