Error message - The remote computer cannot be authenticated because of problems with its certificate

Description

When opening an RDP session with a remote RDP server or computer an error/warning message is displayed "The remote computer could not be authenticated due to problems with its security certificate. It may be unsafe to proceed. Do you want to continue?" 

Cause

This might be caused by the certificate on the remote computer being inherently invalid.  e.g. SHA1 certificates. 

It might be caused by the certificate being self signed, or the SMA not having the CA certificates necessary to validate the computers certificate. 

Resolution

The certificate issue can be resolved by replacing the certificate on the remote computer with one that can be trusted.  But, if the remote computer must be trusted regardless, this workaround will resolve and prevent the error being displayed: 

For trusted systems modify the graphical terminal shortcut to prevent the error indication. 

 

Related Articles

  • How to Provision SMA1000 in Monthly Billing (MSSP Program)
    Read More
  • SMA 1000 Series Support Matrix
    Read More
  • How to Configure SAML 2.0 SSO with Microsoft Entra ID for SonicWall SMA 1000 Series
    Read More
not finding your answers?