Why does the Android device ID / equipment ID change in Android 8.0 (Oreo) or later?

Description

This article covers the change in behavior for Android Mobile Connect 5.0 or later for evaluating EPC policies based on device ID.

Cause

Android 8.0 / Android Oreo / Android "O"  has introduced behavioral change by developers of Android OS.  More info could be found on Google's Documentation.

What Causes Device ID / Equipment ID Change:

  1. Install MC on an Android version below 8.0 (Oreo).
  2. Perform an over-the-air upgrade of the Android OS to version 8.0+.
  3. At this point, the MC device ID will still be the same.
  4. Uninstall Mobile Connect App.
  5. Reinstall Mobile Connect App.
  6. Now the MC device ID will change one time, and should not change again on future reinstalls.

Resolution

  • Login to Secure Mobile Access and navigate to Management Console | User Access | End Point Control | Zone | Device Profile | New | Android | Type Equipment ID.
  • Select Match profile if user has no registered device or to capture new Unique Device Identifier generated for Android 8.0 (Oreo).
  • Once the user logs in the New Device Identifier could be captured from Monitoring | Logging | View Logs | Unregistered device log:

NOTE:  Equipment ID Change is a one-time change and safe for all  future upgrades.

  • Upgrading Mobile Connect to 5.0 or any future version.
  • Upgrading Android OS to any particular version (provided that MC is not uninstalled).

 Affected Mobile Connect versions:

Since this is an OS change, not a change in Mobile Connect, all MC Android versions are affected. These include:

  • MC Android 5.0..
  • MC Android 4.0.x, which is currently in the store.
  • All previous versions of MC Android.

This is similar to the IOS issue Device ID changes on iOS devices when upgrading to Mobile Connect 5.0.

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