Troubleshooting SonicWall CAS Service User Sign-In errors

Description

When we see the below Error on the CAS dashboard for O365 Mail Icon, check and confirm that the SonicWall Service user is not blocked by Conditional access policies. If you see a failure reason due to a conditional access policy, make an exception for the SonicWall Service User.

Error: Unable to create Office365 journal rule and connector that allow for monitoring of emails. This may be related to your organization's security settings. Please contact support for assistance.

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Cause

  •   Conditional access policies or MFA.
  •   Legacy authentication is blocked.
  •   The password was changed, or the user was deleted.

Resolution


  • Login to Microsoft 365 admin center and navigate to Admin | Azure Active Directory.
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  • Navigate to Users from the Azure Menu.
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  • Search for SonicWall-service-user and click on the result.
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  • Click sign-ins after opening the user profile (opened user profile in the previous step). 
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  • Click the most recent failure.
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  • Scroll down in the bottom window to check the ‘Failure Reason'.
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  • If the failure we see is due to an invalid username/password, contact support for further assistance. You may see a different reason, Conditional access etc, if this is the case continue reading.
  • If you see failure reason conditional access, please click the “conditional access tab” in the window to see which policy applied.
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  • Click the name of the policy to see the details and make an exception. It may take some time for the exception to apply, about 10-15 minutes Image

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