SMA 1000 series Support for OESIS V3 v/s V4
03/26/2020
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9294
DESCRIPTION:
SMA 1000 series Support for OESIS V4 with May-hotfix release.
11.4 May Hotfix will now support OESIS Version-4 profiles. We recommend all the customers to move away from OESIS V3 to V4 as OPSWAT has stopped providing updates to V3.
This is being provided in FAQ format as was provided during 12.1 release timeframe.
OESIS V4 support only from May-hotfix on firmware version-11.4.0.
- Until what time will the OESIS V3 libs be supported by OPSWAT? What about the existing V3 profile will it work or not work?
The OESIS V3 libs are already out of support. So the existing V3 device profile may or may not work as expected. - What version of firmware supports V4?
The 11.4 May 2018 hotfix, 12.1 and future releases will support OESIS V4 profiles. - I have installed the latest hotfix for 11.4 version and I see warnings on the Management Console against a few device profiles saying, "There are device profiles using OPSWAT V3 attributes...." and a tool tip saying, "OPSWAT V3 attributes are deprecated". What should I do?

You are suggested to delete the existing profiles and recreate them. The new profiles will be by default OESIS V4 profiles. - I understand that all newly created profiles should be OESIS V4 compliant since OESIS V3 is out of support. However, I need to create a new OESIS V3 compliant profile. Can I do that?
Even though it's not recommended, you can override the default behavior and create a new OESIS V3 compliant device profile by adding a CEM value in the management console: MGMT_ALLOW_NEW_OPSWAT_V3=true . However, creating the newer device profile with V3 standard may or may not work. - Will the OESIS V4 compliant profiles work for older Connect Tunnel clients. For example: 12.0.x or 10.7.2?
No, the clients will need to be upgraded to the latest 11.4 (hotfix) or 12.1.x in order to work based on the new OESIS V4 device profiles. Ideally the Administrator should make use of the "Forced" or "Required” update for CT. Please note that if the zone is configured for quarantine the force upgrade will not work. In this scenario we have to manually install the latest client. - Do we have any changes in the existing functionality of signature update, Files system scanned, or Realtime Protection required?
No we don't have any changes in the functionality of signature update and Realtime Protection. However, there is a minor change for File System Scanned i.e. in OESIS V4 we support "full" Scan of the system. - I see a new category "Antimalware Program" replacing the Antivirus Program and Antispyware Program. What has changed?
The two categories, i.e. Antivirus (AV) and Antispyware (AS) have been merged into Antimalware (AM). This is because many products qualify for both categories.
Steps to create V4 device profile. Select the AntiMalware or Personal firewall for creating the profiles.

Please note that AV and AS are merged as AM.
- Add the check points (version, signature update , file scanned system, Real time protection) based on the requirements.
- Click on Add Current Attributes. The rest of the process is similar to V3 profile creation.
How do I determine if the created device profile is V3 or V4?
- Go to the device profile and expand the selected device profile and you can observe that V3 device profile explicitly ends with “V3”.

The vendor/product name for few products have changed in V4. So in order to migrate the older V3 profile you have to select newer vendor/product name in V4.
CAUSE:
Support for OESIS V4 in 11.4 May Hotfix and V3 will be deprecated, since we're OPSWAT stopped supported for OESIS V3 versions.
If you still want to use OESIS V3 on 11.4 please use the CEM values to enable it, but it may or may not work. Refer more details above.
RESOLUTION:
Please use the 11.4.0-May Hotfix release to support OESIS V4 version.