NOTE: You will want to pre-stage the new tenant with any needed zones, policies, and exclusions prior to migrating the devices.
The recommended migration process is:
ARTICLE NUMBER
000066577
ENVIRONMENT
OVERVIEW
A CylancePROTECT agent may become unregistered when the following occurs:
CAUSE
Devices were unregistered or removed from the Cylance console, which is used to administer CylancePROTECT.
RESOLUTION
Resolution 1:
For the following Registry Key
HKEY_LOCAL_MACHINE\SOFTWARE\Cylance\DesktopCreate a String (REG_SZ) value "InstallToken"=<your installation token here>
Your organization token is located by navigating to Settings > Application > Installation Token.
By default, restrictions are implemented on CylancePROTECT (referred to as Self Protection) so that the user on the device is not able to modify the CylancePROTECT registry hive. It may be necessary to take ownership of the registry hive before making the changes described above.
Resolution 2:
Use PsExec to elevate privilege and push the key down to all Windows devices in your organization. Those that don't require a key are not impacted, but those requesting the key immediately re-register and check into the console:
psexec -s @C:\temp\hosts.txt REG ADD HKLM\SOFTWARE\Cylance\Desktop /v InstallToken /t REG_SZ /d TOKEN /f
Where hosts.txt contains a list of all the hosts and TOKEN represents the Token found by navigating to Settings > Application > Installation Token.
Resolution 3
Use a preferred deployment mechanism (SCCM, BigFix, GPO, etc.) to write to the registry. Use the following format for the .reg file:
+++++
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Cylance\Desktop]
"InstallToken"="<your key here>"
+++++
Important:
Stop the CylancePROTECT service:
Complete the following steps:
sudo launchctl unload /Library/LaunchDaemons/com.cylance.agent_service.plist, and click Return.
Edit the values.xml file:
You can edit the values.xml file to include the new Installation Token. To edit the XML file, you can use TextEdit, the command line, or a bash script.
Resolution 1:
The following command can be used to re-register the agent
/opt/cylance/desktop/cylance -r token
WORKAROUND
Workaround 1: Using TextEdit
Complete the following workaround steps:
/Library/Application\ Support/Cylance/Desktop/registry/LocalMachine/Software/Cylance/Desktop
<value name="InstallToken" type="string">[Installation_Token]</value>
Workaround 2: Using the command line
Complete the following workaround steps:
Note: Nano is used in this example, but you can also use vi or vim.
sudo nano /Library/Application\ Support/Cylance/Desktop/registry/LocalMachine/Software/Cylance/Desktop/values.xml, and click Return.<value name="InstallToken" type="string">[Installation_Token]</value>. Replace [Installation_Token] with the correct install token.
Workaround 3: Using a bash script
Use a bash script to push the key down to all OS X and macOS devices in your organization. Those that don't require a key are not impacted. Those that request the key immediately re-register and check into the console.
Complete the following workaround steps:
1. Create a file (CylanceReRegister.sh) with the following contents:
#!/usr/bin/bash
TOKEN=INSTALLTOKENHERE
FILE="/Library/Application Support/Cylance/Desktop/registry/LocalMachine/Software/Cylance/Desktop/values.xml"
sed -i '' 's/.*<values>.*/&\
<value name="InstallToken" type="string">'$TOKEN'<\/value>/' "$FILE"
Where INSTALLTOKENHERE represents the Token from Settings > Application > Installation Token.
2. Use a preferred deployment mechanism (Casper, etc.) to run the bash script using sudo, as follows:
sudo bash ./CylanceReRegister.sh
ADDITIONAL INFORMATION
Start the CylancePROTECT service:
Complete the following steps:
sudo launchctl load /Library/LaunchDaemons/com.cylance.agent_service.plist, and click Return.