How can I download required tech support files (TSR, settings, GUI logs, trace logs)?
11/03/2020
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DESCRIPTION:
This article covers how to download required tech support files including: TSR, EXP, GUI Logs, & Trace Logs
CAUSE:
If for any reason the firewall is not working as expected this article will explain how to gather required files for support to diagnose and resolve your request more efficiently. Providing all logs can provide a big picture for support to identify any previously unknown or ongoing issue. Streamline your experience with support, upload complete logs upon case creation to save your time spent on the phone or back and forth with support.
TIP: Create your case online and upload these files to your service request before calling into support, you will be routed directly to support, bypassing customer service and significantly reduce your time on the phone:
How to submit a support case online at mysonicwall.com
RESOLUTION:
Resolution for SonicOS 7.X
This release includes significant user interface changes and many new features that are different from the SonicOS 6.5 and earlier firmware. The below resolution is for customers using SonicOS 7.X firmware.
- Log on to the firewall.
- Download Tech Support Report (TSR).
- Click Device in the top navigation menu.
- Navigate to Diagnostics | Tech Support Report.
- Enable all the toggle switches under Configure and then click Download Tech Support Report.
- Download firewall settings.
- Click Device in the top navigation menu.
- Navigate to Settings | Firmware and Settings and click on Import/Export configuration button. Select Export Configuration from the drop down.
- Download firewall logs
- Click Monitor in the top navigation menu.
- Click Logs | System Logs and select Show dropdown list with All Entries.

- Click on the Export button and select Text or CSV options to export the log file to local drive on the PC in desired format.

- Gather trace logs from the Diagnostics page.
- On the address bar, add /settings/diag after the Mgmt as https://<management_ip>/sonicui/7/m/Mgmt/settings/diag
- Click on Internal Settings.
- In the drop down select All + Current, then click Download Trace Log.
- Depending on your browser settings the trace logs may print to your web browser. Highlight the trace logs within your browser and paste them into a notepad. Be sure you paste the entire contents of the trace logs in the notepad before saving. If the entire contents are transferred correctly <end of trace log> should appear at the last line of notepad . Scrolling half way down the web browser printout before highlighting the text helps to copy the complete contents of the trace logs within the web browser.

Resolution for SonicOS 6.5
This release includes significant user interface changes and many new features that are different from the SonicOS 6.2 and earlier firmware. The below resolution is for customers using SonicOS 6.5 firmware.
- Log on to the firewall.
- Download Tech Support Report (TSR).
- Click Investigate in the top navigation menu.
- Navigate to System |Diagnostics..
- Select all the options box under Tech Support Report and then click Download Report.

- Download firewall settings .
- Click Manage in the top navigation menu.
- Navigate to Firmware & Backups and click Export settings button.

- Download firewall logs
- Click Investigate in the top navigation menu.
- Click Event Logs and select Show dropdown list with All Entries.

- Click on the Export icon and select Text or CSV options to export the log file to local drive on the PC in desired format .

- Gather trace logs from the .diag page.
- In your firewall's URL replace "main" with "diag" then hit enter.


- Click on internal settings.

- In the drop down select All + Current, then click Download Trace Log.

- Depending on your browser settings the trace logs may print to your web browser. Highlight the trace logs within your browser and paste them into a notepad. Be sure you paste the entire contents of the trace logs in the notepad before saving. If the entire contents are transferred correctly <end of trace log> should appear at the last line of notepad . Scrolling half way down the web browser printout before highlighting the text helps to copy the complete contents of the trace logs within the web browser.
