Explanation of error "Request failed with status code 500" while importing users from LDAP server

Description

The error "Request failed with status code 500" while importing users from LDAP server is displayed on firewall UI.

Cause

In this scenario we are importing 520 user from Windows Active Directory to firewall local users on TZ 470.

Importing users

During user import, the operation ends with the error “Request failed with status code 500”

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Despite the errors some users are imported for a total of 251 users
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Resolution

The reason is the maximum number of local users handled by the firewall.To check the number of the maximum supported local users TSR must be generated.
Please refer to https://www.sonicwall.com/support/knowledge-base/how-can-i-download-the-required-tech-support-files/170503698742108

Then, open the Tech Support Report with Notepad++, hit CTRL+F to open the search window and search for “Max Local Users”. In this example, the TZ470 supports a maximum of 250 Local Users (buil-in Admin excluded).

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