Email messages stuck in Capture box on HES
03/26/2020 14 People found this article helpful 396,402 Views
Description
Reported Issue:
A set of customers experienced non-delivery of emails routed to Capture Sandbox for analysis. Manual release through “Release from Capture Box” button also failed to deliver these emails.
This affected some Hosted Email Security and Email Security On-Prem customers in the NA and EU region.
Workaround:
Users were able to use “send copy to” feature from the Message Logs UI to delivery emails in some cases.
Cause
Causes of the issue:
This issue was triggered because of communication breakdown between Email Security Service and Capture Service. The communication breakdown affected the default timeout and “Release from Capture Box” features on HES resulting in non-delivery of emails.
Resolution
Fixes:
- A hotfix was applied to all HES servers on 04/14/2019 that would process all new messages as expected.
- Post application of hotfix, all the messages that were not delivered during the error state were pushed for redelivery.
Status Update:
- The hotfix applied on 04/14/2019 has addressed most of the issues and SonicWall Engineering team continues to monitor the mail flow.
- The redelivery of old messages has resulted in some customers receiving duplicate messages. This is mostly for cases where the customer had used “Send Copy to” feature. This is expected.
- There are likely some messages stuck in Capture Sandbox for reasons where downstream server returns a 500-error code. Some examples are – invalid recipients, email box full. This essentially means SonicWall Email Security will not be able to deliver such messages.
- For On-Prem customers, SonicWall has removed the ES 10.0 build from MySonicWall download center and will be releasing a 10.0.1 build next week.
SonicWall apologizes for any inconvenience affecting customers and partners due to these issues. Additional measures have been implemented to proactively identify and resolve any service degradation issues in the future.
Please contact SonicWall support if you still have an unresolved issue with the HES service.
ISSUE ID:
218134
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