The SonicWall Global VPN Client uses an easy setup wizard to guide you through the installation process.
Installing the Global VPN Client requires Administrator rights.
This section explains how to install the Global VPN Client program using the Setup Wizard.
Remove any installed 3rd Party VPN client program before installing the latest SonicWall Global VPN Client. If you have a prior version of Global VPN Client installed, you must uninstall it before installing version 5.
To install Global VPN Client using the Setup Wizard
Download the self‐extracting installer, GVCSetupXX.exe (where XX is either 32 for 32‐bit Windows platforms or 64 for 64‐bit Windows platforms), from MySonicWall > Downloads > Download Center.
GVCSetupXX.exeto launch the Setup Wizard.Click Next to continue to the License Agreement page.
Enable I Accept the terms in the License Agreement, and click Next.
Enter the destination folder in the text field.
Optionally, click Change.. to specify a custom installation location.
Click Install. The Global VPN Client Setup page indicates the status of the installation.
Click Finish to exit the wizard.
After a successful installation, the next action depends on whether you have saved connections:
Navigate to View > Options > General tab to configure the Global VPN Client to launch automatically whenever you log onto your computer.
To install Global VPN Client using the Unified Management
Visit https://account.mysonicwall.com/m/um/signin to login to unified management.
Upon successful completion of login, click Download center in the bottom left.
Choose By Product Line and in Products list select global VPN client.
Expand Global VPN client to see the available installers and click arrow to download the version.
Upgrades from previous versions are not supported. If you have Global VPN Client version 4.10 or earlier installed, you must uninstall that version and reboot your PC before installing version 5. The version 5 installer does not allow upgrading from earlier versions.
To check the current installed GVC version
Navigate to Help > About.
The version will be displayed on the top of the page.
Navigate to Start > Programs > Global VPN Client to launch the Global VPN Client.
Once open, you can manage the dialog box with the following clicks:
To close the Global VPN Client dialog while your established VPN connections remain active:
A message appears notifying you that the Global VPN Client and any enabled connections remain active after the dialog is closed.
If you don’t want this notification to display every time you close the Global VPN Client dialog, select Don’t show me this message again, and click OK.
To open the Global VPN Client dialog:
Right-click the desktop icon, and select Open Global VPN Client.
Exiting the Global VPN Client from the system tray icon menu disables any active VPN connections.
You can specify how the Global VPN Client launches and what notification windows appear. Choose View > Options to display the Options dialog, and use the controls in the General tab to define your settings.
The General tab includes the following settings to control the launch of the Global VPN Client:
| Start this program when I log in | Launches the Global VPN Client when you log into your computer. |
| Warn me before enabling a connection that will block my Internet traffic | Activates a Connection Warning message notifying you that the VPN connection will block local Internet and network traffic. |
| Remember the last window state (closed or open) the next time the program is started | Allows the Global VPN Client to remember the last window state (open or closed) when the program is started. For example, a user can launch the Global VPN Client from the system tray without opening a window on the desktop. |
| When closing the connections window | Specifies how the Global VPN Client behaves when the window is closed. |
|
Minimizes the window to task bar and restores it from the task bar. |
|
The default setting that hides the Global VPN Client window when you close it. You can open the Global VPN Client from the program icon in the system tray. Enabling this setting also displays the Show the notification when I hide the connections window checkbox. |
|
Selecting this checkbox activates the Global VPN Client Hide Notification window whenever you close the Global VPN Client window while the program is still running. The message tells you that the Global VPN Client program continues to run after you close (hide) the window. |
When you launch the Global VPN Client window, the program icon appears in the system tray on the task bar.
This icon provides program and VPN connection status indicators as well as a menu for common SonicWall Global VPN Client commands. Right‐clicking on the Global VPN Client icon in the system tray displays a menu of options for managing the program.
Moving the mouse pointer over the Global VPN Client icon in the system tray displays the number of enabled VPN connections.
The Global VPN Client icon in the system tray also acts as a visual indicator of data passing between the Global VPN Client and the SonicWall gateway.
To export the logs
Click View > Log Viewer.
Click Save to export the logs.