TOTP and SSLVPN users are getting the error: ''User is not authorized''

Description

After introducing TOTP code getting the error ''User XXXX is not authorized''

Image

Cause

Root cause of this issue is that system time on both devices are off by over a minute. Since TOTP code is generated based on time, any inaccuracy in system time could cause code mismatch. Please check if their system time is accurate.

Resolution

Resolution for SonicOS 7.X

This release includes significant user interface changes and many new features that are different from the SonicOS 6.5 and earlier firmware. The below resolution is for customers using SonicOS 7.X firmware.

1.- To discard any issue on TOTP and SSLVPN users setting, please check bellow link. 

https://www.sonicwall.com/support/knowledge-base/how-do-i-configure-2fa-for-ssl-vpn-with-totp/190829123329169/

2.- Force a new NTP synchronization.

2.1.  Navigate to Device|Settings|Time.

2.2.   Under Set Time, enable or disable/enable Set time automatically using NTP and ACCEPT .

Image

Related Articles

  • SSH password authentication fails after OpenSSH upgrade
    Read More
  • Where can I download SonicWall stencils?
    Read More
  • Configuring High Availability Monitoring settings
    Read More
not finding your answers?