en-US
search-icon

Global VPN Client 4.10 Admin Guide

Troubleshooting the Global VPN Client

Tools for Troubleshooting

The SonicWall Global VPN Client provides tools for troubleshooting your VPN connections:

Help Report – Configuring the Log
SonicWall Global VPN Client help system – Accessing SonicWall Global VPN Client Technical Support
Global VPN Client uninstall – Uninstalling the Global VPN Client

Understanding the Global VPN Client Log

The Global VPN Client Log window displays messages about Global VPN Client activities. You can save the messages as well as manage them.

Topics:

Opening the Log Viewer Window

To open the Log Viewer window:
1
Do one of the following:
Click the Show Log button on the Global VPN Client window toolbar.
Choose View > Log Viewer.
Press Ctrl+L.

The Log Viewer window displays this information:

Type - The icon indicating the type of message:
Information -
Warning -
Error -
Time - Date and time the message was generated.
Peer - The IP address or FQDN of the peer.
Message - Text of the message describing the event.

Saving the Current Log

Click the Save button to save the current log to a .txt file. When you save the current log to a file, the Global VPN Client automatically adds a Help Report containing useful information regarding the condition of the SonicWall Global VPN Client as well as the system it’s running on for troubleshooting. The Help Report information is inserted at the beginning of the log file. See Generating a Help Report for more information.

* 
TIP: For a complete listing of Log Viewer messages, see Log Viewer Messages .

Managing Log Messages

The Log Viewer provides the following features to help you manage log messages:

To save a current log to a .txt file, click the Save button on the toolbar, press Ctrl+S, or choose File > Save. When you save a Log Viewer file, the Global VPN Client automatically adds a report containing useful information regarding the condition of the SonicWall Global VPN Client as well as the system it is running on.
To select all messages, press Ctrl+A or choose Edit > Select All.
To copy log contents for pasting into another application, select the messages you want to copy, then press Ctrl+C or choose Edit > Copy.
To display less detailed information in the log viewer, click the Filter Messages button on the toolbar or choose View > Filter Messages.
To search the log messages for a character string, do one of the following:
Click the Find icon on the toolbar.
Choose Edit > Find and enter the string in the Find dialog.

In the dialog, you can select Match Whole Word Only, Match Case, and Up or Down for the search direction.

Click the Find Next icon to search. Once a string is entered in the Find dialog, you can click the X to close the dialog, then use the Find Next and Find Previous icons in the toolbar.
To clear current log information, do one of these:
Click Clear on the toolbar.
Press Crtl+X.
Choose Edit > Clear.
To hide or show the toolbar in the Log Viewer window, choose View > Toolbar to toggle the toolbar on or off.
To hide or show the status bar in the Log Viewer window, choose View > Status Bar to toggle the status bar on or off.

Configuring the Log

The Logging tab in the View > Options dialog specifies the settings for configuring the Global VPN Client Log behavior.

Maximum number of log messages to keep - Specifies the maximum number of log messages kept in the log file.
Log ISAKMP header information - Enables the logging of ISAKMP header information.
Log dead peer detection packets - Enables the logging of dead peer detection packets.
Log NAT keep-alive packets - Enables the logging of NAT keep-alive packets.
Enable automatic logging of messages to file - Enables automatic logging of messages to a file as specified in the Auto-Logging window.
Settings - Displays the Auto-Logging dialog; see Configuring Auto-Logging.

Configuring Auto-Logging

Clicking on Settings displays the Auto-Logging dialog for specifying settings for automatic logging of messages to a file. Log files are saved as text (.txt) files.

Enter the name of the auto-log file - Specifies the file in which to save the logging messages. Clicking on the Browse button allows you to specify the location of your auto-log file. If only a file name is specified (no path is given in the file name), the log file is created in the user’s TEMP directory.
View Auto-Log File - Displays the entire log file up to 71,000 lines.
Overwrite existing file when auto-logging starts - Overwrites the existing auto-log file when auto-logging is started.
Set size limit on auto-log file - Limits the maximum size of the log file.
Maximum auto-log file size - Specifies the maximum file size in KB or MB.
When auto-log size limit is reached - Specifies the action to take when the auto-log file reaches the maximum size:
Ask me what to do - When the log file reaches the maximum size, prompts to choose either Stop auto-logging or Overwrite auto-log file.
Stop auto-logging - Stops auto-logging when the maximum file size is reached.
Overwrite auto-log file - Overwrites the existing auto-log file after the maximum file size is reached.

Generating a Help Report

Choosing Help > Generate Report in the Global VPN Client window displays the Global VPN Client Report dialog.

Generate Report creates a report containing useful information for getting help in solving any problems you may be experiencing. The report contains information regarding the condition of the SonicWall Global VPN Client as well as the system it is running on:

Version information
Drivers
System information
IP addresses
Route table
Current log messages

To view the report in your default text editor window, click View.

To save the report to a text file, click Save As.
To send the report via email, click Send.
To close the report window without taking any action, click Don’t Send.

Accessing SonicWall Global VPN Client Technical Support

SonicWall’s comprehensive support services protect your network security investment and offer the support you need — when you need it. SonicWall Global VPN Client support is included as part of the support program of your SonicWall network security appliance.

Selecting Help > Technical Support accesses the SonicWall Support site at:

https://support.sonicwall.com

The SonicWall Support site offer a full range of support services including extensive online resources and information on SonicWall’s enhanced support programs. You can purchase/activate SonicWall Support Services through your MySonicWall account at:

http://www.mysonicwall.com

Viewing Help Topics

Selecting Help > Help Topics displays the SonicWall Global VPN Client help system window. You can access help topics using the following options:

Contents - displays help in a table of contents view.
Index - displays help in an alphabetical topic view.
Search - allows you to search the help system using keywords.

Uninstalling the Global VPN Client

You can easily uninstall the SonicWall Global VPN Client and choose to save or delete your VPN connections as part of the uninstall process.

* 
NOTE: You must exit the SonicWall Global VPN Client before uninstalling the program.

To uninstall the SonicWall Global VPN Client:

1
Launch the Windows Control Panel
2
Double-click Programs and Features.
3
Select the Global VPN Client.
4
Click Remove.
5
In the Confirm File Deletion dialog, click Yes or OK to confirm the removal of the SonicWall Global VPN Client.
6
If you want to:
Delete all your existing VPN connection profiles, choose Delete all individual user profiles. If you leave this setting unchecked, the VPN connection profiles are saved and appear again when you install the SonicWall Global VPN Client at another time.
Retain the same SonicWall VPN Adapter MAC address the next time you install the Global VPN Client, choose Retain MAC Address.
7
Click Next.
8
After the Global VPN Client is removed, restart your computer when prompted to do so.