Unable to access the Web UI after importing a certificate (SSL_ERROR_HANDSHAKE_FAILURE_ALERT)

Description

Problem: SonicWall WebUI not accessible after importing a certificate for Web Management. Accessing through HTTPS redirects immediately to HTTP even if the redirect was not enabled. Error in the browser: " SSL_ERROR_HANDSHAKE_FAILURE_ALERT ".

Cause

Root cause: The Option “Enable Client Certificate Check” was checked under System > Administration but the certificate was not validated/imported into the browser.

Resolution

Solution:

1.       Access the SonicWall through  SSH and disable the Client Certificate Check:
How to disable "Enable Client Certificate Check" option over the CLI?

2.       Double check if the Certificate you are using is installed and validated, if not import the root and intermediate certificates into the browser.

3.       In the Web UI select the Certificate for Firewall management.

NOTE:  If you enable “Client Certificate Check” you need to install the certificate on every browser.

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